Home » Linux OS and Software » How-To » Ubuntu 8.04 LTS Minimal: "perl: warning: Setting locale failed."
Thu, 13 November 2008 21:03 Go to next message
Registered: November 2008
Messages: 18
I'm constantly getting the following error when running apt-get (among other commands) on my freshly (re)installed Ubuntu VPS Server:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LANG = "en_CA.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory


If you experience the same problem, you can fix it by installing the language-pack-en package (or the language pack for your language of choice), like so:

# apt-get install language-pack-en
Thu, 20 November 2008 15:29 Go to previous message
sehe  is currently offline sehe
Registered: November 2008
Messages: 1
Thanks a lot

I was at a loss with that one!
Previous Topic:venet nic
Next Topic:Keeping your Fedora or CentOS system updated
Goto Forum:
  


Current Time: Sun Dec 17 12:19:34 EST 2017
.:: Contact :: Home ::.

Powered by: FUDforum 2.7.7.
Copyright ©2001-2006 FUD Forum Bulletin Board Software