Home » Linux OS and Software » Discussion » clamav-daemon install poblem
Sun, 19 July 2009 18:01 Go to next message
Registered: July 2009
Messages: 1
I have a City server running Ubuntu 8.10 LAMP and am trying to replicate a mail server config I have used successfully before using Postfix and Dovecot.
I have a problem installing ClamAV which seems to be related to kernel modules. When using 'apt-get install clamav-daemon' I get the following error

FATAL: Could not load /lib/modules/2.6.18-128.1.1.el5.028stab062.3/modules.dep: No such file or directory

This seems to be when the script attempts to load apparmour.

I checked the file location shown and there is nothing there.

I suspect that this is due to the kernel being shared between the VPSes on the hardware.

Does anyone know if that is the case and, if so, is there a solution or workaround for it?

Thanks in advance,

Peter
Mon, 20 July 2009 02:28 Go to previous message
Registered: November 2007
Messages: 512
That error would seem to indicate that you're missing a configuration file on your server (modules.dep) but its odd that clamav would need it. Thats probably due to an error in the package at the repository apt is using.

You might be able to fool apt by creating an empty modules.dep file yourself before you run the install.

If that fails, you may want to switch repositories, use a more recent version of Unbuntu, or try Debian instead.


[Updated on: Mon, 20 July 2009 02:32]

Previous Topic:gentoo iptables masquerading
Next Topic:Problem with Remote Desktop (Ubuntu 9.01 LAMP)
Goto Forum:
  


Current Time: Sun Sep 15 20:00:18 EDT 2019
.:: Contact :: Home ::.

Powered by: FUDforum 2.7.7.
Copyright ©2001-2006 FUD Forum Bulletin Board Software