Home » Linux OS and Software » How-To » Upgrading the Gentoo Minimal Profile
Mon, 17 January 2011 23:39
Registered: June 2010
Messages: 4
Hey all,

As the template provided by VPSVille for the Gentoo install is really out of date, it takes a couple extra steps to get it upgraded to a functional state. I thought I'd post the steps required here in case someone needs them...

1)
emerge --sync

At this point you will get a notice saying your version of portage is out of date, so run:

2)
emerge portage


You will need to upgrade the system profile now to something in the 10.x series. I would suggest the default 10.0 profile

3)
eselect profile list

This will show you the available profiles

4)
eselect profile set 1


You now need to update the working environment

5)
env-update && source /etc/profile


Attempting to update portage at this point will give you a really frustrating circular error about blocked packages:

[blocks B     ] >=dev-lang/python-2.6.6:2.6 (">=dev-lang/python-2.6.6:2.6" is blocking sys-apps/portage-2.1.6.13)
[blocks B     ] <sys-apps/portage-2.1.9 ("<sys-apps/portage-2.1.9" is blocking dev-lang/python-2.6.6-r1)


The best way of fixing this is to manually build python:

wget http://tinderbox.dev.gentoo.org/default-linux/x86/dev-lang/python-3.1.2-r4.tbz2 
cd / 
tar xfpj root/python-3.1.2-r4.tbz2 
rm /usr/bin/python 
ln -s /usr/bin/python3.1 /usr/bin/python 


You also now need to manually rebuild portage:

cd 
wget http://tinderbox.dev.gentoo.org/default-linux/x86/sys-apps/portage-2.1.9.24.tbz2 
cd / 
tar xfpj root/portage-2.1.9.24.tbz2 


Now that that's done, lets update python:

python-updater


And finally, now we can go in and upgrade portage to the latest version:

emerge portage


This will update a whole whack of packages, but after this you should be good to go and update the rest of the system packages.
Previous Topic:How do i keep programs running after disconnecting from the vps?
Next Topic:How-To secure your VPS with iptables
Goto Forum:
  


Current Time: Sat Sep 23 10:40:18 EDT 2017
.:: Contact :: Home ::.

Powered by: FUDforum 2.7.7.
Copyright ©2001-2006 FUD Forum Bulletin Board Software