Home » Linux OS and Software » How-To » mail to mydomain.com doesn't get delivered
Fri, 27 April 2012 16:49 Go to next message
Registered: April 2012
Messages: 3
Outbound mail to users at other domains is properly delivered, but mail to same domain as the website domain is not delivered. How can we fix that? Although we want outbound mail from the vps, we don't want to use it for the organization's mail.

Here is an example of the message sent to root@mydomain.com for an 'undeliverable' message to staffer@mydomain.com:

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

staffer@mydomain.com


------ This is a copy of the message, including all the headers. ------

Return-path: <root@web1.mydomain.com>
Received: from root by web1.mydomain.com with local (Exim 4.67)
(envelope-from <root@web1.mydomain.com>)
id 1SNmm2-0007Zb-JL
for staffer@mydomain.com; Fri, 27 Apr 2012 15:08:19 +0000
To: staffer@mydomain.com
Subject: TEsting
Message-Id: <E1SNmm2-0007Zb-JL@web1.mydomain.com>
From: root <root@web1.mydomain.com>
Date: Fri, 27 Apr 2012 15:08:13 +0000


NB: web1.mydomain.com seems to be the server name, though the main way to access the site is mydomain.com.
Fri, 27 April 2012 18:45 Go to previous messageGo to next message
Registered: November 2007
Messages: 505
What do the MX entry in the DNS servers for mydomain.com look like?
Fri, 27 April 2012 23:07 Go to previous messageGo to next message
Registered: April 2012
Messages: 3
On dnswatch.info they come out as:
mydomain.com. MX 3600 20 ALT2.ASPMX.L.GOOGLE.COM.
mydomain.com. MX 3600 10 ASPMX.L.GOOGLE.COM.
mydomain.com. MX 3600 20 ALT1.ASPMX.L.GOOGLE.COM.
mydomain.com. MX 3600 30 ASPMX4.GOOGLEMAIL.COM.
mydomain.com. MX 3600 30 ASPMX3.GOOGLEMAIL.COM.
mydomain.com. MX 3600 30 ASPMX2.GOOGLEMAIL.COM.
mydomain.com. MX 3600 30 ASPMX5.GOOGLEMAIL.COM.


As an attempt at solving this I have tried changing the default /etc/resolv.conf from:
nameserver 208.67.220.220
nameserver 208.67.222.222

to:
search mydomain.com mydomain.org
nameserver 66.150.161.138
nameserver 63.251.83.88
nameserver 63.251.171.92

where these IPs are the A records of the FQDN's for the first three of four NS records for mydomain.com and mydomain.org. In other words, I looked up the NS records for mydomain.com and mydomain.org, which gave me domains, then I did A record searches on those names to get the IPs.

I'm not sure if this was a good or bad idea.
Mon, 30 April 2012 09:36 Go to previous messageGo to next message
Registered: April 2012
Messages: 3
So this doesn't work:

php_network_getaddresses: getaddrinfo failed: Name or service not known

Any advice from staff based on the MX entries?
Wed, 09 May 2012 20:21 Go to previous message
Registered: November 2007
Messages: 505
The IPs you are using as DNS resolvers are not on this network, so I'm not sure what they are supposed to be doing. The ones you erased were valid DNS resolvers (opendns.com).

The rest of your setting show you are using Google as your mail servers for both incoming and outgoing mail.
Previous Topic:PEAR Package Installed?
Next Topic:Unable to upgrade to recent versions of udev
Goto Forum:
  


Current Time: Sat Sep 23 10:52:29 EDT 2017
.:: Contact :: Home ::.

Powered by: FUDforum 2.7.7.
Copyright ©2001-2006 FUD Forum Bulletin Board Software